
Primavera P6 Quick Start Guide
A Beginner's Guide for Construction Professionals

What is Primavera P6?

Presented by Compass Consult

1.Introduction

Primavera P6 is Oracle's enterprise project portfolio management software, essential for 
planning, scheduling, and controlling large-scale, complex construction projects. It is the 
industry's gold standard for its robust capabilities in managing multi-faceted projects with 
numerous activities, resources, and constraints.
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• This Quick Start Guide is designed for: - Construction project

•  managers new to Primavera P6 - Schedulers transitioning

•  from other software platforms - Project controls professionals 

seeking to refresh their P6 knowledge - Construction team

•  members who need to understand P6 outputs

Why Primavera P6 is Essential
for Construction Project Management

Construction projects involve multiple stakeholders, tight deadlines, complex dependencies, 

and significant financial investments. Primavera P6 provides construction professionals with

• Comprehensive scheduling capabilities to manage thousands of activities

• Resource optimization tools to efficiently allocate labor, equipment, and materials

• Cost management features to track budgets and forecast expenses

• Risk assessment tools to identify and mitigate potential issues

• Reporting functions to communicate progress to stakeholders

Who This Guide is For How to Use This Guide Effectively

This guide follows a practical, step-by-step approach to help you quickly 

become productive with Primavera P6. We recommend

• Reading the guide sequentially from start to finish

• Practicing each concept in P6 as you learn it Using the guide as a 

reference when working on actual projects

• Exploring the additional resources mentioned in the final section
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2. Getting Started Primavera P6
System Requirements
Before installing Primavera P6, ensure your system meets these minimum requirements:

• For Primavera P6 Professional (Desktop Client): Operating System: Windows 10 

or 11- Processor: 1.5 GHz or faster - RAM: 4 GB minimum (8 GB recommended) - Hard 

Disk: 5GB of available space - Display: 1280 x 800 resolution

• For Primavera P6 EPPM (Web-Based): Web Browser: Google Chrome, Microsoft 

Edge, or Mozilla Firefox (latest versions) - Internet Connection: Broadband connection

Installation Basics
For P6 Professional:

1. Obtain the installation files from Oracle or your organization's IT
2. Run the setup file and follow the installation wizard 3. Choose the installation type (Typical is department recommended for most users)
4. Select the installation location
5. Complete the installation process

For P6 EPPM:

1. Obtain the URL, username, and password from your system administrator 
2.  2. No installation is required as it runs in your web browser

Licensing Options
Primavera P6 offers several licensing options:

1. Named User Plus (NUP) : Licenses assigned to specific individuals

2. Processor : Based on the number of processors running the software

3. Cloud Services : Subscription-based access to cloud-hosted P6

Most construction companies use either the Named User Plus model for 
their core scheduling team or the cloud-based option for broader access
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For P6 Professional: 

1. Launch P6 Professional from your Start menu or desktop shortcut 2. Enter your username and 

password 3. Select the database you wish to connect to 4. If prompted, select your user profile

For P6 EPPM: 

1. Navigate to the P6 EPPM URL in your web browser 2. Enter 

your username and password 3. If prompted, select your 

preferred language and time zone

First-Time Login Process
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1. Menu Bar: Contains drop-down menus for all P6 functions 
2. Toolbars: Provides quick access to common commands
3. Navigation Bar: Located on the left side, allows switching between different views
4. Detail Windows: Displays information about the selected item
5. Activity Network/Gantt Chart: Visual representation of the project schedule
6. Status Bar: Shows current database, user, and other status information

Key Views in P6: - Activities: The main view for creating and managing project activities-
WBS: For organizing the project's work breakdown structure - Resources: For managing project resources - Projects: For managing multiple projects - 
Dashboards: For viewing project performance metrics

Understanding the Interface Layout

The P6 interface consists of several key components:
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1. Click File > New
2. Select Project and click OK
3. In the New Project dialog box:
4. Enter a unique Project ID (e.g., CC-2025-001)
5. Provide a descriptive Project Name (e.g., Main Street Office Building)
6. Select the appropriate Responsible Manager
7. Choose a Planning Unit (typically hours or days for construction)
8. Set the Start Date for your project
9. Click Finish to create the project

To create a new project in P6 :

Project Creation Wizard

1. Go to Enterprise > Calendars
2. Click Add to create a new calendar or select an existing one to modify
3. Set the standard working hours (typically 8:00 AM to 4:30 PM)
4. Define working days (usually Monday through Friday)
5. Add holidays and other non-working days
6. Assign the calendar to your project by going to Projects > Projects, selecting your project,
    and choosing the calendar in the Defaults tab

The project calendar defines working and non-working times

Setting Up the Project Calendar

3. Creating Your First Project
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Defining Project Properties

1. With your project open, go to Project > Project Information
2. In the General tab:
3. Set the Project Status (Active, Planned, etc.)
4. Define Must Finish By  date if applicable
5. Select appropriate Priority level
6. In the Dates tab:
7. Review and adjust project start and finish dates
8. Set any required constraints
9. In the Settings tab:
10. Choose scheduling options
11. Set critical activity parameters
12. Click OK to save changes

Configure additional project settings:

Understanding the Work Breakdown Structure (WBS)

1. Go to the WBS view in the navigation bar
2. Click Add to create a new WBS element
3. For a typical construction project, create top-level WBS elements such as:
4. 4. 1.0 Pre-Construction
5. Site Work
6. 3.0 Foundation
7. 4.0 Structure
8. 5.0 Exterior Envelope
9. 6.0 Interior Finishes
10. 7.0 MEP Systems
11. 8.0 Commissioning
12. 9.0 Project Closeout
13. Add sub-elements as needed (e.g., 4.1 Steel Erection, 4.2 Concrete Slabs)
14. Assign codes, responsible managers, and other attributes as required

The WBS organizes your project into manageable components:

Creating and Organizing Activities

1. Switch to the Activities view
2. Select the WBS element where you want to add activities
3. Click Add to create a new activity
4. For each activity, define:
5. Activity ID: A unique identifier (e.g., FDN-100)
6. Activity Name: A descriptive name (e.g., "Pour Foundation")
7. Original Duration: Estimated time to complete the activity
8. Activity Type: Task, Start Milestone, or Finish Milestone
9. WBS: The WBS element it belongs to
10. Organize activities by:
11. Using activity codes (Location, Phase, Responsibility, etc.)
12. Creating activity layouts with grouping and sorting
13. Using filters to focus on specific activities

Activities are the individual tasks that
make up your project:
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4. Scheduling Fundamentals
Activity Types and Durations
P6 supports several activity types:
1. Task: Standard activity with a duration
2. Start Milestone: An event marking the beginning of a phase (zero duration)
3. Finish Milestone: An event marking the completion of a phase (zero duration)
4. Level of Effort (LOE): Support activity that spans the duration of related activities
5. WBS Summary: Automatically summarizes activities within a WBS element

To set activity durations: 

1. Select the activity in the Activities view
2. Enter the Original Duration in the appropriate time unit
3. For construction activities, consider:
4. Historical performance data
5. Resource availability
6. Complexity of work
7. Seasonal factors
8. Potential risks

Creating Relationships Between Activities

Activities in a schedule are connected through logical relationships:
1. Select the predecessor activity Right-click and select Add Step
2. Choose the successor activity
3. Define the relationship type
4. Set lag time if needed 

Alternatively: 1. Use the Relationships tab in the bottom pane 
2. Click Add 3. Select the predecessor or successor 4. Define 
the relationship type and lag

Understanding Different Relationship Types

P6 supports four types of relationships:
1. Finish to Start (FS): The successor cannot
    start until the predecessor finishes
2. Example: Cannot begin framing walls until
     the concrete foundation cures
3. Start to Start (SS): The successor cannot
     start until the predecessor starts
4. Example: Site security can begin when site
     mobilization starts
5. Finish to Finish (FF): The successor cannot
     finish until the predecessor finishes
6. Example: Final inspection cannot finish until
    punch list work finishes
7. Start to Finish (SF): The successor cannot
    finish until the predecessor starts
8. Example: Temporary power cannot finish until
    permanent power starts
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Critical Path Analysis
The critical path represents the sequence of activities 
that determine the project’s duration:
1. Go to View > Schedule to run the schedule 

calculation
2. Activities on the critical path will be highlighted 

(typically in red)
3. To analyze the critical path:
4. Look for activities with zero or minimal float
5. Focus optimization efforts on these activities
6. Monitor these activities closely during execution
7. To display the critical path more clearly:
8. Go to View > Bars
9. Ensure Critical is selected
10. Adjust the display settings as needed

Setting Constraints and Deadlines

Constraints limit when activities can start or finish:

1. Select the activity to constrain
2. Go to the Status tab in the bottom pane
3. Set the Constraint Type:
4. Start On: Activity must start on a specific date
5. Start On or After: Activity cannot start before a specific date
6. Finish On: Activity must finish on a specific date
7. Finish On or Before: Activity cannot finish after a specific date
8. Set the Constraint Date

Deadlines are target dates that don't constrain the schedule:

1. Select the activity
2. In the Dates tab, set the Deadline date
3. P6 will show a warning if the activity is forecasted to finish after its      
deadline
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5. Resource Management
Creating a Resource Pool

1. Go to Enterprise > Resources
2. Click Add to create a new resource
3. Define the resource properties:
4. Resource ID: Unique identifier
5. Resource Name: Descriptive name
6. Resource Type: Labor, Non-Labor, or Material
7. Unit of Measure: Hours for labor, appropriate units for others
8. Calendar: Working calendar for the resource
9. Email: Contact information if applicable
10. Organize resources into hierarchical structures using the
     Resource Breakdown Structure

Assigning Resources to Activities

To assign resources to activities:
1. Select the activity in the Activities view
2. Go to the Resources tab in the bottom pane
3. Click Assign
4. Select the resource(s) to assign
5. Define the Budgeted Units or Units per Time Period
6. Set the Cost Account if tracking costs
7. Click Assign to complete the assignment

For construction projects, consider: -
Assigning crews rather than individual workers -
Using role-based resources for flexibility - Accounting for
equipment mobilization and demobilization
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Resource Leveling Basics
Resource leveling adjusts the schedule to resolve resource overallocation:
1. Go to Tools > Level Resources
2. In the Level Resources dialog:
3. Select the resources to level
4. Set the leveling priority
5. Choose leveling options (preserve scheduled early dates, etc.)
6. Define the time period for leveling
7. Click Level to perform the leveling
8. Review the results and make manual adjustments as needed

Understanding Resource Histograms
Resource histograms visually display resource allocation over time:
1. Go to View > Resource Usage Profile
2. Select the resource(s) to display
3. Choose the time period and units
4. Analyze the histogram to identify:
5. Periods of overallocation (exceeding availability)
6. Periods of underutilization
7. Resource usage patterns
8. Adjust the schedule or resource assignments to optimize resource usage
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6. Cost Management
Setting Up Cost Accounts
Cost accounts categorize and track project expenses:
1. Go to Enterprise > Cost Accounts.
2. Click Add to create a new cost account.
3. Define the cost account structure:
4. ID: Unique identifier
5. Description: Purpose of the account
6. Type: Labor, Material, Nonlabor, or Expense
7. Organize cost accounts hierarchically to match your company's accounting system

Assigning Costs to Activities

Understanding Earned Value Management (EVM)

Budget Tracking Fundamentals

To assign costs to activities:

1. Select the activity in the Activities view
2. Go to the Resources tab in the bottom pane
3. For each assigned resource:
4. Set the Price/Unit (hourly rate, unit cost, etc.)
5. Define the Budgeted Cost
6. Assign the appropriate Cost Account
7. For expenses without resources:
8. Go to the Expenses tab
9. Click Add
10. Enter the expense details and cost account

Earned Value Management (EVM) measures project performance:
1. Ensure activities have:
2. Accurate budgeted costs
3. Appropriate percent complete method
4. Current status updates
5. Key EVM metrics in P6:
6. Planned Value (PV): Budgeted cost of scheduled work
7. Earned Value (EV): Budgeted cost of completed work
8. Actual Cost (AC): Actual cost of completed work
9. Cost Variance (CV): EV - AC
10. Schedule Variance (SV): EV - PV
11. Cost Performance Index (CPI): EV / AC
12. Schedule Performance Index (SPI): EV / PV
13. To view EVM data:
14. Go to View > Show on Top > Earned Value
15. Configure the display to show relevant metrics

To track project budgets in P6:

1. Establish a baseline (see Section 7)
2. Regularly update activity progress and costs
3. Compare actual costs to budgeted costs
4. Monitor the Estimate to Complete (ETC) and Estimate at Completion (EAC)
5. Use the Project Expenses view to track non-activity costs
6. Create cost-focused reports and dashboards
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7.Tracking and Updating Projects
Baseline Creation and Importance

Progress Tracking Methods
P6 offers several methods for tracking activity progress:
1. Physical % Complete: Manual entry based on field assessment
2. Duration % Complete: Based on remaining duration
3. Units % Complete: Based on resource units used
4. Steps: Breaking activities into weighted steps that are marked complete
To set the tracking method: 1. Select the activity 2. Go to the General tab 3. Set the %
Complete Type 4. For step-based tracking, use the Steps tab to define steps

A baseline is a snapshot of your
project plan used for comparison:

1. Go to Project > Maintain Baselines
2. Click Add
3. Enter a name for the baseline
    (e.g., "Bid Baseline" or "Contract Baseline")
4. Select the data to include (typically all options)
5. Click OK to create the baseline

Baselines are crucial for: - Measuring schedule
performance - Identifying delays and
variances - Supporting change orders and
claims - Documenting the original plan

Updating Activity Status
To update activity progress:
1. Go to the Activities view
2. Select the activity to update
3. Update one or more of the following:
4. Actual Start: Date the activity began
5. Actual Finish: Date the activity completed
6. % Complete: Current completion percentage
7. Remaining Duration: Time needed to complete
8. Activity Status: Not Started, In Progress, or Completed
9. For resource updates:
10. Go to the Resources tab
11. Update Actual Units and Actual Costs
12. Click Schedule to recalculate the schedule

Best practices for construction updates: - Update the
schedule weekly - Collect data from field supervisors –
Focus on activities in progress and those starting soon –
Document reasons for delays - Update resource usage and
costs simultaneously

Schedule Comparison
To compare the current schedule with the baseline:

1. Go to View > Bars
2. Enable display of baseline bars
3. Analyze variances between baseline and current dates
4. For detailed comparison:
5. Go to Tools > Schedule Comparison
6. Select the baseline to compare against
7. Choose comparison options
8. Generate the comparison report
9. Focus on:
10. Activities with finish date variances
11. Changes to the critical path
12. Float consumption
13. Milestone delays
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8. Reporting Basics
Standard Reports Overview

P6 includes many standard reports
for construction projects:
1. Schedule Reports:
2. Critical Path Report
3. Total Float Report
4. Schedule Log
5. Resource Reports:
6. Resource Usage
7. Resource Loading
8. Resource Allocation
9. Cost Reports:
10. Cost Loading
11. Earned Value
12. Cash Flow
13. Management Reports:
14. Management Summary Milestone Status Variance Reports

To access standard reports: 
Go to Tools > Reports 2. Browse the report categories 3.
Select and run the desired report

Creating Custom Reports

To create a custom report:
1. Go to Tools > Report Wizard
2. Follow the wizard steps:
3. Select the report type
4. Choose the data to include
5. Define grouping and sorting
6. Set filters to focus on specific data
7. Configure the layout and formatting
8. Save the report for future use
9. Run the report to generate output

Printing Schedules and Reports
To print schedules and Gantt charts:

1. Go to File > Print
2. In the Print dialog:
3. Select the printer
4. Chose print options (time scale, page setup, etc.)
5. Set the date range to print
6. Define header and footer content
7. Preview the output before printing
8. For large schedules:
9. Consider printing to PDF
10. Use plotter for large-format prints
11. Break the schedule into logical sections

Exporting Data to Excel
To export P6 data to Excel:

1. Set up the Activities view with the columns
    you want to export
2. Go to File > Export
3. Select Spreadsheet (XLS) as the file type
4. Choose the data to export
5. Specify the export file location
6. Click Export to create the Excel file

For more control: 1. Copy data directly from the Activities
view 2. Paste into Excel 3. Format as needed
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9. Tips for Construction Projects
Industry-Specific Best Practices
Optimize P6 for construction scheduling:

1. Use standardized WBS templates for
    different project types
2. Create activity ID systems that reflect
     work areas and trades
3. Develop standard activity codes for
     filtering and grouping:
4. Area/Location
5. Responsibility
6. Phase
7. Trade
8. Bid Package
9. Implement resource curves that reflect
     construction productivity patterns
10. Use calendars effectively to account for:
11. Weather constraints
12. Permit restrictions
13. Union work rules
14. Inspection availability
15. Create activity templates for repetitive work

Common Pitfalls to Avoid
Watch out for these common mistakes:

1. Excessive detail: Too many activities make updates difficult
2. Insufficient detail: Too few activities hide critical work
3. Missing logic: Activities without proper relationships
4. Overuse of constraints: Restricts schedule flexibility
5. Unrealistic durations: Overly optimistic or pessimistic estimates
6. Ignoring resource limitations: Scheduling more work than
     resources can handle
7. Infrequent updates: Schedules become obsolete quickly
8. Poor documentation: Failing to record delay reasons and changes

Optimizing P6 for Construction Workflows
Streamline your P6 usage:

1. Create custom layouts for different users and purposes:
2. Executive overview
3. Detailed construction schedule
4. Two-week lookahead
5. Resource loading view
6. Cost tracking view
7. Use global change to make bulk updates
8. Implement user-defined fields for construction-specific data
9. Create filters for quick access to relevant activities
10. Develop dashboard views for project status at a glance
11. Use notebook topics to document assumptions and issues
12. Implement thresholds to highlight schedule issues
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10. Next Steps and Resources
Advanced Features to Explore

Once you're comfortable with the basics,
explore these advanced capabilities:

1. Risk Analysis: Using P6 Risk to
    quantify schedule uncertainty
2. Resource Optimization:
     Advanced leveling and allocation techniques
3. Claim Analysis: Forensic scheduling and delay analysis
4. Multiple Project Management: Managing programs and portfolios
5. Earned Value Management: Advanced tracking and forecasting
6. What-If Analysis: Evaluating alternative scenarios
7. Global Change: Making bulk updates efficiently
8. User-Defined Fields: Customizing P6 for specific needs
9. Reflection Projects: Comparing multiple schedule versions
10. Activity Step Templates: Standardizing progress tracking

Training Resources
Continue your P6 learning journey:

1. Oracle University: Official P6 training courses
2. Oracle Documentation: User guides and tutorial
3. YouTube Channels: Video tutorials and tips
4. Industry Forums: Peer discussions and solutions
5. Books: Comprehensive guides for construction scheduling
6. Webinars: Free and paid educational sessions
7. User Groups: Local and virtual communities

How Compass Consult Can Support
Your Primavera P6 Implementation

Compass Consult offers comprehensive Primavera P6 services:

1. Implementation Support:
2. Software installation and configuration
3. Database setup and optimization
4. Integration with existing systems
5. Custom template development
6.Training Programs:
7. Beginner to advanced courses
8. Role-specific training
9. Hands-on workshops
10. Customized curriculum
11. Scheduling Services:
12. Schedule development and review
13. Resource loading and optimization
14. Progress updates and analysis
15. Recovery scheduling
16. Ongoing Support:
17. Technical troubleshooting
18. Schedule health checks
19. Best practice guidance
20. Performance optimization

Contact Compass Consult today to discuss how
we can help you maximize your Primavera P6
investment and improve your project outcomes.

Where to Get Help

When you encounter challenges:

1. P6 Help System: Built-in documentation
2. Oracle Support: Official technical assistance
3. Community Forums: User discussions and solutions
4. LinkedIn Groups: Professional networking and advice
5. Local User Groups: In-person assistance and networking
6. Consulting Services: Expert guidance for complex issues

© Compass Consult. All rights reserved. . This guide is provided as an educational resource for construction professionals. Primavera P6 is a registered trademark of Oracle Corporation.
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